Ny feature: SSL beskyttelse af webhoteller

1292242898_Shield_YellowVi er enormt glade for at kunne præsentere en meget efterspurgt funktion, nemlig SSL beskyttelse af webhoteller.
Vi har længe ventet på den helt rigtige måde at kunne levere SSL til vores kunder på. Den mener vi nu at have fundet og har derfor klargjort alle vores PHP servere til det.

SSL (https) bruges til at kryptere overførelsen mellem webserveren (din hjemmeside) og din besøgende. SSL er efterhånden blevet et krav af mange besøgende og services. Fx. kræver Facebook at man har SSL beskyttelse på sine endpoints. Samtidig er mange besøgende glade for at kunne se en side er SSL beskyttet når de fx. er i gang med en bestilling.

happy

Kræver SSL en dedikeret IP adresse?

Nej. Vi gør brug af SNI. Det betyder at flere SSL sites kan køre på samme IP. Præcist på samme måde som ikke-SSL sites kan.
SNI understøttes ikke i Internet Explorer på Windows XP, samt i Internet Explorer 6. Så disse besøgende vil altså ikke kunne bruge SSL beskyttelsen hos os. Pt. udgør dette cirka 3-7% af besøgende på en normal hjemmeside. Det tal bliver selvfølgelig mindre for hver dag der går. Det er en konsekvens vi godt mener man kan leve med, når vi omvendt mener alternativet med en dedikeret IP adresse per hjemmeside ikke er optimal. Især ikke når verden er ved at løbe tør for IPv4 adresser.

Hvad koster det?

Prisen er 1 EUR/md for at have aktiveret SSL på sit webhotel, uanset webhotel-pakke. Dvs. I alt 12 EUR/år, eller cirka 90kr/år.

Vi har samtidig forhandlet os frem til nye priser på SSL certifikater, så disse kan nu også købes til langt lavere priser. Se alle priserne her.

Virker det på ASP webhoteller?

Nej, det virker pt. ikke på ASP webhoteller. SNI virker kun på Windows 2012 (IIS 8) og det er ikke alle vores servere der kører dette endnu. Det er noget vi arbejder på at løse. Ønsker du SSL på Windows/ASP er den eneste mulighed derfor stadig at købe en VPS.

Opdatering: SSL virker nu på Windows webhoteller.

Virker det på subdomæner?

Nej. SSL beskyttelse virker pt. kun på det domæne du har webhotellet til. Det virker ikke på subdomæner eller tilknyttede domæner.

Kan jeg bruge mit eget SSL certifikat?

Ja. Du kan importere og bruge dit allerede eksisterende SSL certifikat.
Hvis du ikke allerede har et certifikat kan du købe et hos os igennem vores Kontrolpanel.

Er det let at bruge og opsætte?

Vi gjort vores ypperste for at gøre aktiveringen og bestillingen af SSL så let som muligt. It just works.

SSL kan aktiveres under menupunktet “Administration” og “Tilvalg” i vores kontrolpanel, hvor du også kan læse nærmere.

God fornøjelse :)

Status på PHP 5.3 og PHP 5.2

Vi får ofte henvendelser fra kunder som spørger hvad vores standpunkt er i forhold til PHP 5.3.

PHP 5.3 har været frigivet i noget tid, desværre er den nye version ikke 100% bagudkompatibel med PHP 5.2, og det giver problemer for nogle enkelte kunder. Især osCommerce kunder har problemer med den nye PHP version. Problemerne er ofte få, men det kan nemt være en uoverskuelig opgave at løse for kunder som ikke har den store kendskab til PHP. PHP 5.3 virker dog problemfrit hos langt de fleste kunder, og fx. WordPress virker også helt perfekt.

Vi gør altid vores bedste for at være på forkant med teknologien, men i dette tilfælde har vi valgt at vente med at opgradere til PHP 5.3 på alle servere, da vi ved det kan resultere i problemer for mange.

Status er derfor at linux14.unoeuro.com (nye kunder) og alle fremtidige servere benytter PHP 5.3, og alle ‘ældre’ servere benytter PHP 5.2. Ønsker man, som ny kunde, PHP 5.2 kan man blot bede vores support om at flytte ens webhotel til en anden server.

Vi kan naturligvis ikke blot se bort fra PHP 5.3, og vi har selvfølgelig også i sinde at opgradere alle servere på et tidspunkt. Vi har pt. ikke sat en deadline, men forventer under alle omstændigheder at opgradere samtlige servere senere på året.

Kunder kan allerede nu hjælpe dem selv, ved at sørge for at man altid benytter den nyeste version af sit CMS og e-shop system.

PHP har udgivet en guide til opgradering fra PHP 5.2 til PHP 5.3, og det er især de inkompatibel ændringer der er relevante.

Få endnu mere fart på WordPress

WordPress er hurtigt blevet det absolut mest udbredte blogsystem hos UnoEuro, og i også verden.

Med vores 1-Click install har det aldrig været nemmere at få WordPress installeret og komme igang med at blogge, helt smertefrit. Hos os er du ej plaget af problemer med safe_mode, som du kan risikere hos nogle andre udbydere.

WordPress er kendt for hastighed og brugervenlighed out-of-the-box. WordPress kan også bruges til meget mere end en blogs, mange vælger også at bruge det som CMS system til deres hjemmeside. Dette kan betyde at ens WordPress installation hurtig kan blive tung og ressourcekrævende. Det samme gælder for nogle bloggere som ser en stor stigning i antal besøg.

En af vore kunder, Claus Heinrich, har skrevet en virkelig god guide til hvordan man får mere fart på WordPress, og gør den bæredygtig over for mange besøg. Læs Sæt fart på din WordPress blog med Caching, GZIP, Minify & CDN og især Opsætning af W3 Total Cache til WordPress som alle kan drage stor nytte af.

Et CDN er et netværk af servere der hurtigt og effektivt kan levere statiske filer (billeder, video og javascript filer). Fordelen ved at outsource disse filer til et CDN, er at det fjerner belastningen på webserveren og uddelegere visningen af filerne til CDN netværket. Det vil normalt også resultere i hurtigere visningen af filerne. Hvis du har en WordPress installation med mange billeder, er den en rigtig god ide at kigge på et CDN, som kan fås til meget billige penge.

Det er også vigtigt at stille et kritisk øje til de forskellige ekstra plugins man vælger at installere. Vi ser ofte at nogle plugins kan være rigtig dårligt sat sammen, og dermed skabe store problemer hvis ens blog har mange besøg.

Med W3 Total Cache vil din WordPress installation blive væsentlig hurtigere, og have et væsentlig mindre ressourceforbrug. Til glæde for både dig, dine besøgende og os :)

PHP opgraderet til version 5.2.8

php-med-trans

Samtlige Linux servere (PHP Suiter) er d.d opgraderet til PHP version 5.2.8 og medfølger nu mcrypt og XSL udvidelserne.

linux2.unoeuro.com og linux3.unoeuro.com medfølger ikke XSL. Hardwaren i disse servere er planlagt til at blive opgraderet snarest, og begge servere vil herefter også inkludere XSL.

Vi er samtidig så småt ved at gøre klar til PHP6, som jo medfølger fjernelsen af SAFE_MODE funktionaliteten – Det skal nok blive interessant.